summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad78e441e..74692d970 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,6 +135,10 @@ if(NOT WIN32)
endif()
endif()
+if(NOT EMSCRIPTEN)
+ find_package(OpenGL COMPONENTS OpenGL)
+endif()
+
if(MSVC)
find_package(Editbin REQUIRED)
endif()
@@ -245,6 +249,7 @@ if(NOT OPTION_DEDICATED)
link_package(Fontconfig TARGET Fontconfig::Fontconfig)
link_package(ICU_lx)
link_package(ICU_i18n)
+ link_package(OpenGL TARGET OpenGL::GL)
endif()
if(APPLE)