summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-01-16 16:43:04 +0100
committerMichael Lutz <michi@icosahedron.de>2021-02-22 22:16:07 +0100
commitef478ade649add1ab1706370ff53bcb0c32798d1 (patch)
treebf39b20030319377edec1b654fe4e8c7ba4594a3 /CMakeLists.txt
parentaf4d32357cc4cea6878c61c366378477e62915d0 (diff)
downloadopenttd-ef478ade649add1ab1706370ff53bcb0c32798d1.tar.xz
Add: [Win32] Video driver that uses OpenGL to transfer the video buffer to the screen.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad78e441e..74692d970 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,6 +135,10 @@ if(NOT WIN32)
endif()
endif()
+if(NOT EMSCRIPTEN)
+ find_package(OpenGL COMPONENTS OpenGL)
+endif()
+
if(MSVC)
find_package(Editbin REQUIRED)
endif()
@@ -245,6 +249,7 @@ if(NOT OPTION_DEDICATED)
link_package(Fontconfig TARGET Fontconfig::Fontconfig)
link_package(ICU_lx)
link_package(ICU_i18n)
+ link_package(OpenGL TARGET OpenGL::GL)
endif()
if(APPLE)