summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPatric Stout <truebrain@openttd.org>2019-04-07 12:00:36 +0200
committerglx22 <glx22@users.noreply.github.com>2020-06-05 19:36:05 +0200
commitb7643b1d36cb41eb6712042761c13b9819fcbe74 (patch)
tree3bb422ed83832cf197692aef82f142a187a28af6 /CMakeLists.txt
parent56d54cf60eb5814f77dfcce91cf12879f01e1d1b (diff)
downloadopenttd-b7643b1d36cb41eb6712042761c13b9819fcbe74.tar.xz
Add: create bundles via CPack
CPack works closely together with CMake to do the right thing in terms of bundling (called 'package'). This generates all the packaging we need, and some more.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1ffa9ecc..77ae77cef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -224,3 +224,5 @@ endif (CMAKE_SIZEOF_VOID_P EQUAL 8)
include(CreateRegression)
create_regression()
+
+include(InstallAndPackage)