summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7215f42c3..156b2be1d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,6 +210,7 @@ s1 = '/^\#define AUTHORS \([^\\]\)/{;s//\1/;$(sed_filter);p;q;}'
s2 = '/^\#define AUTHORS \\\\/{;n;$(sed_filter);p;q;}'
# FIXME: handle *.sh
../AUTHORS: $(SOURCES)
+ rm -f $@-t
( \
set -e; \
echo "Here are the names of the programs in this package,"; \
@@ -224,4 +225,5 @@ s2 = '/^\#define AUTHORS \\\\/{;n;$(sed_filter);p;q;}'
echo "$$prog: $$a"; \
fi; \
done | sort -u ) > $@-t
+ chmod a-w $@-t
mv $@-t $@