summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2002-10-13 06:48:42 +0000
committerJim Meyering <jim@meyering.net>2002-10-13 06:48:42 +0000
commit797d72c3cca5df2397b8a9a485ce9cad8c9349a5 (patch)
treecd2e1fa2355bb3152bc86852e6b23bdbc9877205 /src/Makefile.am
parent331dd19c54780aba82dad663620b47c89a548022 (diff)
downloadcoreutils-797d72c3cca5df2397b8a9a485ce9cad8c9349a5.tar.xz
(../AUTHORS): Make it read-only.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7215f42c3..156b2be1d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,6 +210,7 @@ s1 = '/^\#define AUTHORS \([^\\]\)/{;s//\1/;$(sed_filter);p;q;}'
s2 = '/^\#define AUTHORS \\\\/{;n;$(sed_filter);p;q;}'
# FIXME: handle *.sh
../AUTHORS: $(SOURCES)
+ rm -f $@-t
( \
set -e; \
echo "Here are the names of the programs in this package,"; \
@@ -224,4 +225,5 @@ s2 = '/^\#define AUTHORS \\\\/{;n;$(sed_filter);p;q;}'
echo "$$prog: $$a"; \
fi; \
done | sort -u ) > $@-t
+ chmod a-w $@-t
mv $@-t $@