summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ae8650d9..4999ca14d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ALL_RECURSIVE_TARGETS =
-SUBDIRS = lib po . tests gnulib-tests
+SUBDIRS = lib po . gnulib-tests
changelog_etc = \
ChangeLog-2005 \
@@ -72,11 +72,6 @@ $(srcdir)/src/cu-progs.mk: $(gen_progs_lists)
ACLOCAL_AMFLAGS = -I m4
-# Some tests always need root privileges, others need them only sometimes.
-ALL_RECURSIVE_TARGETS += check-root
-check-root:
- cd tests && $(MAKE) $@ SUBDIRS=
-
# Shortcut targets to make it easier to run (very) expensive tests.
check-expensive:
$(MAKE) check RUN_EXPENSIVE_TESTS=yes
@@ -184,3 +179,4 @@ check-git-hook-script-sync:
include $(top_srcdir)/src/local.mk
include $(top_srcdir)/doc/local.mk
include $(top_srcdir)/man/local.mk
+include $(top_srcdir)/tests/local.mk