summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-09-02 21:55:12 +0200
committerJim Meyering <meyering@redhat.com>2012-09-05 08:48:29 +0200
commit21b5147fd8ee493727e2a3ca17b3bf695c5024d3 (patch)
treeb14cc2e5d51d761e9c825e0c0dd56f7fdce85cea /Makefile.am
parent24fb6d91b6b5b460d5d0b4f5c76d4a954f928040 (diff)
downloadcoreutils-21b5147fd8ee493727e2a3ca17b3bf695c5024d3.tar.xz
build: don't use recursive make for tests/ subdirectory
* Makefile.am (SUBDIRS): Remove 'tests'. (include): The '$(top_srcdir)/tests/local.mk' file. (check-root): Remove this convenience target, it's no longer needed now that the "real" check-root target once in 'tests/Makefile' will land in the top-level makefile. * configure.ac (AC_CONFIG_FILES): Remove 'tests/Makefile'. * tests/Makefile.am: Rename ... * tests/local.mk: ... like this, with a lot of adjustments. * tests/init.cfg: Move ... * init.cfg: ... here. This is necessary, for a limitation of the gnulib-provided 'tests/init.sh', which unconditionally look for 'init.cfg' in the $(srcdir) directory. * tests/*/*.sh: Adjust: expect init.sh to be in '$srcdir/tests', not in '$srcdir', and extend $PATH with './src', not with '../src'. * tests/Coreutils.pm: Adjust similarly. * tests/pr/pr-tests.pl ($pfx): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ae8650d9..4999ca14d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ALL_RECURSIVE_TARGETS =
-SUBDIRS = lib po . tests gnulib-tests
+SUBDIRS = lib po . gnulib-tests
changelog_etc = \
ChangeLog-2005 \
@@ -72,11 +72,6 @@ $(srcdir)/src/cu-progs.mk: $(gen_progs_lists)
ACLOCAL_AMFLAGS = -I m4
-# Some tests always need root privileges, others need them only sometimes.
-ALL_RECURSIVE_TARGETS += check-root
-check-root:
- cd tests && $(MAKE) $@ SUBDIRS=
-
# Shortcut targets to make it easier to run (very) expensive tests.
check-expensive:
$(MAKE) check RUN_EXPENSIVE_TESTS=yes
@@ -184,3 +179,4 @@ check-git-hook-script-sync:
include $(top_srcdir)/src/local.mk
include $(top_srcdir)/doc/local.mk
include $(top_srcdir)/man/local.mk
+include $(top_srcdir)/tests/local.mk