summaryrefslogtreecommitdiff
path: root/tests/sort/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-08-26 03:51:33 +0000
committerJim Meyering <jim@meyering.net>1996-08-26 03:51:33 +0000
commite8f73104749c4f0f0d4620106dc5f6fe471ddc00 (patch)
treedd0defb0ab3e36ce5f1c335749e4ff0f4f2b7a6d /tests/sort/Makefile.am
parent3e1ecd65dd4f0f7e8e3e00cb87d4f707177cd0ee (diff)
downloadcoreutils-e8f73104749c4f0f0d4620106dc5f6fe471ddc00.tar.xz
(EXTRA_DIST): Add $x-tests.
($x-tests): Guard dependencies with @MAINT@.
Diffstat (limited to 'tests/sort/Makefile.am')
-rw-r--r--tests/sort/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/sort/Makefile.am b/tests/sort/Makefile.am
index cd092fbb5..a5d65cc05 100644
--- a/tests/sort/Makefile.am
+++ b/tests/sort/Makefile.am
@@ -18,7 +18,7 @@ exp = $(in:.in=.exp)
out = $(in:.in=.out)
err = $(in:.in=.err)
-EXTRA_DIST = build-script.pl Test.pm $(in) $(exp)
+EXTRA_DIST = build-script.pl Test.pm $x-tests $(in) $(exp)
noinst_SCRIPTS = $x-tests
PERL = @PERL@
@@ -26,7 +26,7 @@ editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
TESTS = $x-tests
-$x-tests: build-script Test.pm
+$x-tests: @MAINT@ build-script Test.pm
./build-script ../../src/$x > $@.n
mv $@.n $@
chmod 755 $@