summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKamil Dudka <kdudka@redhat.com>2009-01-13 18:35:00 +0100
committerJim Meyering <meyering@redhat.com>2009-01-14 09:09:22 +0100
commitd01338eb3d30e5634f1b4d4179c229f54eea0b44 (patch)
tree6ed873717bb12faed3300b9be390aaabee40fa74 /tests/Makefile.am
parenta99c35b04d9ab601e4fa98319c56fbdbde6b420a (diff)
downloadcoreutils-d01338eb3d30e5634f1b4d4179c229f54eea0b44.tar.xz
cp/mv: add --no-clobber (-n) option to not overwrite target
* src/cp.c (usage): Show new option -n in --help. (main): Handle new option -n. * src/mv.c (usage): Show new option -n in --help. (main): Handle new option -n. * doc/coreutils.texi: Document new cp/mv option -n. * tests/cp/cp-i: Add tests for -f, -i and -n options. * tests/mv/mv-n: New test for mv -n. * tests/Makefile.am: Add test mv/mv-n to the list. * NEWS: Mention the change.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8dbbe9f26..6dce9cdbb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -379,6 +379,7 @@ TESTS = \
mv/into-self-3 \
mv/into-self-4 \
mv/leak-fd \
+ mv/mv-n \
mv/mv-special-1 \
mv/no-target-dir \
mv/part-fail \