summaryrefslogtreecommitdiff
path: root/sip4/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-01-15 20:52:48 +0100
committerErich Eckner <erich.eckner.ext@bestsecret.com>2023-01-18 10:15:05 +0100
commit807b8dc4015336c351cf160dc8491ceaf4fe7fc8 (patch)
treec59f49b0031a5e3a750939ff74757de9d6f39bce /sip4/PKGBUILD
parenta7ef143368e91000c88b50c632e330888008da89 (diff)
downloadarchlinuxewe-807b8dc4015336c351cf160dc8491ceaf4fe7fc8.tar.xz
sip4: fix _pinned_dependencies
Diffstat (limited to 'sip4/PKGBUILD')
-rw-r--r--sip4/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/sip4/PKGBUILD b/sip4/PKGBUILD
index 4c8f1f622..3ab4fae31 100644
--- a/sip4/PKGBUILD
+++ b/sip4/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=sip4
pkgname=(sip4 python-sip4)
pkgver=4.19.25
-pkgrel=3
+pkgrel=1
arch=(x86_64)
url='https://www.riverbankcomputing.com/software/sip/intro'
license=('custom:"sip"')
@@ -28,7 +28,10 @@ build() {
package_sip4() {
pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
- depends=(glibc)
+ _pinned_dependencies=(
+ 'glibc>=2.36'
+ )
+ depends=("${_pinned_dependencies[@]}")
replaces=('sip<5')
cd build
@@ -42,7 +45,9 @@ package_sip4() {
package_python-sip4() {
pkgdesc="Python SIP4 bindings for C and C++ libraries"
- depends=(python)
+ _pinned_dependencies=(
+ )
+ depends=(python "${_pinned_dependencies[@]}")
provides=(python-sip)
replaces=(python-sip)