summaryrefslogtreecommitdiff
path: root/sip4/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-01-15 20:48:57 +0100
committerErich Eckner <erich.eckner.ext@bestsecret.com>2023-01-18 10:15:05 +0100
commita7ef143368e91000c88b50c632e330888008da89 (patch)
treea79863cf46dc525a6968eb91752f0118beab8b3d /sip4/PKGBUILD
parentb9fb8d546b9b8805faec0175341c0ac9158e309f (diff)
downloadarchlinuxewe-a7ef143368e91000c88b50c632e330888008da89.tar.xz
sip4 new
Diffstat (limited to 'sip4/PKGBUILD')
-rw-r--r--sip4/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/sip4/PKGBUILD b/sip4/PKGBUILD
new file mode 100644
index 000000000..4c8f1f622
--- /dev/null
+++ b/sip4/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
+
+pkgbase=sip4
+pkgname=(sip4 python-sip4)
+pkgver=4.19.25
+pkgrel=3
+arch=(x86_64)
+url='https://www.riverbankcomputing.com/software/sip/intro'
+license=('custom:"sip"')
+makedepends=(python)
+source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
+sha256sums=('b39d93e937647807bac23579edbff25fe46d16213f708370072574ab1f1b4211')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ python ../sip-$pkgver/configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ make
+}
+
+package_sip4() {
+ pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+ depends=(glibc)
+ replaces=('sip<5')
+
+ cd build
+ make DESTDIR="$pkgdir" install -C sipgen
+# move sip.h to /usr/include
+ mv "$pkgdir"/usr/include/{python*/sip.h,}
+ rm -r "$pkgdir"/usr/include/python*
+
+ install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python-sip4() {
+ pkgdesc="Python SIP4 bindings for C and C++ libraries"
+ depends=(python)
+ provides=(python-sip)
+ replaces=(python-sip)
+
+ cd build
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/{bin,include} # conflicts with sip
+
+ install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}