summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2021-04-13 08:10:38 -0400
committerEli Schwartz <eschwartz@archlinux.org>2021-04-13 08:10:38 -0400
commit6a7e9cad7640c74f05398e2d2c92386312748d9e (patch)
treeeb1190085f610865d31df0a19320983148044b92
parenta37665566b3a0581dc6934123d9edd031dde19f6 (diff)
downloadpacman-static-6a7e9cad7640c74f05398e2d2c92386312748d9e.tar.xz
upgpkg: pacman-static 5.2.2-5
Make bz2 actually use the musl-gcc compiler. Before it was using regular gcc, which should not work (but sometimes did, mysteriously, on my machine). Because the bz2 Makefile does not respect environment $CC.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b17454a..7922f80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacman-static
pkgdesc = Statically-compiled pacman (to fix or install systems without libc)
pkgver = 5.2.2
- pkgrel = 4
+ pkgrel = 5
url = https://www.archlinux.org/pacman/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 62f1132..013a1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _libarchive_ver=3.5.1
_gpgerrorver=1.42
_libassuanver=2.5.5
_gpgmever=1.15.1
-pkgrel=4
+pkgrel=5
pkgdesc="Statically-compiled pacman (to fix or install systems without libc)"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://www.archlinux.org/pacman/"
@@ -178,7 +178,7 @@ build() {
# bzip2
cd "${srcdir}"/bzip2-${_bzipver}
- sed -i "s|-O2|${CFLAGS}|g" Makefile
+ sed -i "s|-O2|${CFLAGS}|g;s|CC=gcc|CC=${CC}|g" Makefile
make libbz2.a
install -Dvm644 bzlib.h "${srcdir}"/temp/usr/include/
install -Dvm644 libbz2.a "${srcdir}"/temp/usr/lib/