summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-07 18:39:25 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-07 18:39:25 +0100
commit509b9e592821d9875c15b23b7de916e1cb3f0808 (patch)
tree4c28d0e8d4ce3962a7cb0572662c3b6321309fa4 /build-support
parent0b308c2adc9622b466ed51a60eb863f185c263d2 (diff)
downloadpackages-509b9e592821d9875c15b23b7de916e1cb3f0808.tar.xz
moved libfm-extra to disabled build-support
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/libfm-extra/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/build-support/disabled/libfm-extra/PKGBUILD b/build-support/disabled/libfm-extra/PKGBUILD
new file mode 100644
index 00000000..3ee20db8
--- /dev/null
+++ b/build-support/disabled/libfm-extra/PKGBUILD
@@ -0,0 +1,33 @@
+# breaking the cycle with menu-cache on i486
+depends=(${depends[@]//menu-cache/})
+depends_i686+=(menu-cache)
+depends_pentium4=("${depends_i686[@]}")
+
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|./configure --with-extra-only |
+ /mv.*\/usr\/bin/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_libfm | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk2 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+ eval "$(
+ declare -f package_libfm-gtk3 | \
+ sed '
+ s/mv\(.*\)/(mv\1) || true/
+ '
+ )"
+fi