summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-15 16:27:50 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-15 16:27:50 +0100
commit48d73fadbe164266506c0572015d07a16143678a (patch)
tree364fd8d9a0299c517f683fc5fe7af43b50e1a112 /build-support
parent95cb49f989b1e3d7feb949c5a06e224d735e24bf (diff)
downloadpackages-48d73fadbe164266506c0572015d07a16143678a.tar.xz
removed ghc92-bin and add ghc90-bin to build-support
Diffstat (limited to 'build-support')
-rw-r--r--build-support/ghc90-bin/PKGBUILD (renamed from build-support/ghc92-bin/PKGBUILD)42
-rw-r--r--build-support/ghc90-bin/ghc.install (renamed from build-support/ghc92-bin/ghc.install)4
2 files changed, 23 insertions, 23 deletions
diff --git a/build-support/ghc92-bin/PKGBUILD b/build-support/ghc90-bin/PKGBUILD
index 691e3431..fedad497 100644
--- a/build-support/ghc92-bin/PKGBUILD
+++ b/build-support/ghc90-bin/PKGBUILD
@@ -3,12 +3,12 @@
# Contributor: Rudy Matela <rudy@matela.com.br>
#
# This package can coexist with the latest version of GHC.
-# If you would like to compile GHC yourself (AUR: ghc9.2),
+# If you would like to compile GHC yourself (AUR: ghc9.0),
# you can use this to bootstrap compilation.
-pkgname=ghc92-bin
-pkgver=9.2.1
+pkgname=ghc9.0-bin
+pkgver=9.0.1
pkgrel=1
-pkgdesc='Legacy binary GHC 9.2 installed on /usr/bin/ghc-9.2 (Oct/2021 - Oct/2021).'
+pkgdesc='Legacy binary GHC 9.0 installed on /usr/bin/ghc-9.0 (Feb/2021 - Feb/2021).'
arch=('i486' 'i686' 'pentium4')
url='http://www.haskell.org/ghc/'
license=('custom')
@@ -17,11 +17,11 @@ makedepends=( 'perl' 'libxslt' 'docbook-xsl' 'ncurses5-compat-libs')
checkdepends=('python2')
install='ghc.install'
options=('staticlibs')
-provides=('ghc9.2')
-conflicts=('ghc9.2')
+provides=('ghc9.0')
+conflicts=('ghc9.0')
source=("https://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-i386-deb9-linux.tar.xz")
noextract=("ghc-${pkgver}-${CARCH}-deb10-linux.tar.xz")
-sha256sums=('6daa9e983fbe5af5a3c449c92e5b331d2ecb8e76ea07fc4e237ba5ff27af2c45')
+sha256sums=('c253e7eb62cc9da6524c491c85ec8d3727c2ca6035a8653388e636aaa30a2a0f')
prepare() {
# for some reason, bsdtar cannot unpack this file:
@@ -32,11 +32,11 @@ prepare() {
build() {
cd ghc-${pkgver}
- sed -i 's,"$bindir/ghc","$bindir/ghc-9.2",' utils/runghc/runghc.wrapper
+ sed -i 's,"$bindir/ghc","$bindir/ghc-9.0",' utils/runghc/runghc.wrapper
./configure \
--prefix=/usr \
- --docdir=/usr/share/doc/ghc-9.2
+ --docdir=/usr/share/doc/ghc-9.0
}
package() {
@@ -44,18 +44,18 @@ package() {
make DESTDIR=${pkgdir} install
- mv ${pkgdir}/usr/bin/ghc ${pkgdir}/usr/bin/ghc-9.2
- mv ${pkgdir}/usr/bin/ghci ${pkgdir}/usr/bin/ghci-9.2
- mv ${pkgdir}/usr/bin/ghc-pkg ${pkgdir}/usr/bin/ghc-pkg-9.2
- mv ${pkgdir}/usr/bin/haddock ${pkgdir}/usr/bin/haddock-ghc-9.2
- mv ${pkgdir}/usr/bin/hp2ps ${pkgdir}/usr/bin/hp2ps-ghc-9.2
- mv ${pkgdir}/usr/bin/hpc ${pkgdir}/usr/bin/hpc-ghc-9.2
- mv ${pkgdir}/usr/bin/hsc2hs ${pkgdir}/usr/bin/hsc2hs-ghc-9.2
- mv ${pkgdir}/usr/bin/runghc ${pkgdir}/usr/bin/runghc-9.2
- rm ${pkgdir}/usr/bin/runhaskell # use runghc-9.2 instead
+ mv ${pkgdir}/usr/bin/ghc ${pkgdir}/usr/bin/ghc-9.0
+ mv ${pkgdir}/usr/bin/ghci ${pkgdir}/usr/bin/ghci-9.0
+ mv ${pkgdir}/usr/bin/ghc-pkg ${pkgdir}/usr/bin/ghc-pkg-9.0
+ mv ${pkgdir}/usr/bin/haddock ${pkgdir}/usr/bin/haddock-ghc-9.0
+ mv ${pkgdir}/usr/bin/hp2ps ${pkgdir}/usr/bin/hp2ps-ghc-9.0
+ mv ${pkgdir}/usr/bin/hpc ${pkgdir}/usr/bin/hpc-ghc-9.0
+ mv ${pkgdir}/usr/bin/hsc2hs ${pkgdir}/usr/bin/hsc2hs-ghc-9.0
+ mv ${pkgdir}/usr/bin/runghc ${pkgdir}/usr/bin/runghc-9.0
+ rm ${pkgdir}/usr/bin/runhaskell # use runghc-9.0 instead
- mv ${pkgdir}/usr/share/man/man1/ghc.1 ${pkgdir}/usr/share/man/man1/ghc-9.2
+ mv ${pkgdir}/usr/share/man/man1/ghc.1 ${pkgdir}/usr/share/man/man1/ghc-9.0
- install -d ${pkgdir}/usr/share/licenses/ghc-9.2
- install -m644 LICENSE ${pkgdir}/usr/share/licenses/ghc-9.2
+ install -d ${pkgdir}/usr/share/licenses/ghc-9.0
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/ghc-9.0
}
diff --git a/build-support/ghc92-bin/ghc.install b/build-support/ghc90-bin/ghc.install
index 1a1e0420..68eed631 100644
--- a/build-support/ghc92-bin/ghc.install
+++ b/build-support/ghc90-bin/ghc.install
@@ -1,10 +1,10 @@
pre_upgrade() {
echo '==> Unregistering cabalized packages...'
- [[ -d /usr/share/haskell-ghc-9.2 ]] && find /usr/share/haskell-ghc-9.2 -maxdepth 2 -name 'unregister.sh' -exec {} \;
+ [[ -d /usr/share/haskell-ghc-9.0 ]] && find /usr/share/haskell-ghc-9.0 -maxdepth 2 -name 'unregister.sh' -exec {} \;
echo '==> Done.'
}
post_upgrade() {
echo '==> All cabalized packages need to be reinstalled now.'
- echo '==> See /usr/share/haskell-ghc-9.2/ and ghc-pkg-9.2 list --user for a tentative list of affected packages.'
+ echo '==> See /usr/share/haskell-ghc-9.0/ and ghc-pkg-9.0 list --user for a tentative list of affected packages.'
}