summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2017-08-12 20:44:42 +0200
committerErich Eckner <git@eckner.net>2017-08-12 20:44:42 +0200
commit99bd551e345f11e5b10c8365b61480d5c6d57578 (patch)
treef231a7ed551ae74aa008a1d3747ab631ed19d752
parentc80fe20d6944485a766538b516094e22e7052f8f (diff)
downloadreport-installed-packages-99bd551e345f11e5b10c8365b61480d5c6d57578.tar.xz
Makefile newv0.0
-rw-r--r--.gitignore1
-rw-r--r--Makefile61
-rwxr-xr-xreport-installed-packages.in (renamed from report-installed-packages)0
3 files changed, 62 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..07b832c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+report-installed-packages
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..21dce0b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,61 @@
+#
+# report-installed-packages - report about installed (and therefore presumably working) packages from testing
+#
+# Copyright (c) 2017 Erich Eckner <opensource at eckner dot net>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+# USA.
+#
+
+DESTDIR =
+BINDIR = /usr/bin
+
+VERSION = 0.0
+
+all: report-installed-packages
+
+%: %.in
+ sed " \
+ s/#VERSION#/$(VERSION)/; \
+ s@#BINDIR#@$(BINDIR)@; \
+ s@#ETCDIR#@$(ETCDIR)@; \
+ s@#HELPTEXT#\(\s\+\)#@ --help \1display this help and exit\n --version\1display version and exit@; \
+ " $< > $@
+ [ "$@" = "report-installed-packages" ] && chmod +x "$@" || true
+
+%.1: % man.commons
+ grep -v "^$<(" man.commons | sed '/^\[SEE ALSO]$$/{n;:a;N;/\[/b;s/\n/, /;ta;}' > "$<.common" && \
+ help2man \
+ -n 'Report about installed packages from testing' \
+ -o "$@" -N --include $<.common --no-discard-stderr "./$<"
+
+.PHONY: install dist clean
+
+install: all
+ install -D -m0755 report-installed-packages $(DESTDIR)$(BINDIR)/report-installed-packages
+
+clean:
+ ls -A | \
+ grep "^\($(shell sed 's|\.|\\.|; s|\*|.*|; s|$$|\\|' .gitignore | tr '\n' '\|')\)\$$" | \
+ xargs -r rm
+
+dist: clean
+ git status --porcelain 2> /dev/null | grep -q "\S" && (git add .; git commit -m"neue Version: $(VERSION)") || true
+ ! git tag -d v$(VERSION) 2> /dev/null
+ git tag v$(VERSION)
+ git push
+ git push --tags
+
+# End of file
diff --git a/report-installed-packages b/report-installed-packages.in
index db80ea1..db80ea1 100755
--- a/report-installed-packages
+++ b/report-installed-packages.in