summaryrefslogtreecommitdiff
path: root/src/script/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/script/api/CMakeLists.txt')
-rw-r--r--src/script/api/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/script/api/CMakeLists.txt b/src/script/api/CMakeLists.txt
index 9bc4183f1..c21707d43 100644
--- a/src/script/api/CMakeLists.txt
+++ b/src/script/api/CMakeLists.txt
@@ -131,6 +131,10 @@ foreach(API "ai;AI" "game;GS" "template;Template")
)
endforeach()
+if(OPTION_TOOLS_ONLY)
+ return()
+endif()
+
add_library(openttd::script_api ALIAS script_api)