summaryrefslogtreecommitdiff
path: root/os/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'os/debian/rules')
-rwxr-xr-xos/debian/rules29
1 files changed, 6 insertions, 23 deletions
diff --git a/os/debian/rules b/os/debian/rules
index d6fa65dbf..1ac6c90ef 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -6,22 +6,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-DEFAULT_PACKAGE := openttd
-# Find the package name from the topmost changelog entry.
-# Is this the best way to do this?
-PACKAGE = $(shell cat debian/changelog | head -1 | cut -f1 -d' ')
-
-debian/control:
- # Generate control file
- sed 's/PACKAGE/$(PACKAGE)/' debian/control.in > debian/control
-
- # TODO: How to do this using makefile conditionals?
- if [ "$(PACKAGE)" != "$(DEFAULT_PACKAGE)" ]; then \
- echo "Provides: $(DEFAULT_PACKAGE)" >> debian/control ; \
- echo "Conflicts: $(DEFAULT_PACKAGE)" >> debian/control ; \
- fi;
-
-configure: debian/control configure-stamp
+configure: configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
@@ -29,20 +14,20 @@ configure-stamp:
touch configure-stamp
-build: debian/control configure build-stamp
+build: configure build-stamp
build-stamp:
dh_testdir
# Add here commands to compile the package.
- ./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/$(PACKAGE)
+ ./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/openttd
$(MAKE)
#/usr/bin/docbook-to-man debian/openttd.sgml > openttd.1
touch build-stamp
-clean: debian/control
+clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
@@ -54,10 +39,8 @@ clean: debian/control
[ ! -f Makefile ] || $(MAKE) distclean
dh_clean
- # Clean up generated control file
- -rm debian/control
-install: debian/control build
+install: build
dh_testdir
dh_testroot
dh_clean -k
@@ -71,7 +54,7 @@ binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
-binary-arch: debian/control build install
+binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs changelog.txt