summaryrefslogtreecommitdiff
path: root/media/baseset/orig_extra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'media/baseset/orig_extra/CMakeLists.txt')
-rw-r--r--media/baseset/orig_extra/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/media/baseset/orig_extra/CMakeLists.txt b/media/baseset/orig_extra/CMakeLists.txt
new file mode 100644
index 000000000..f865a8dd0
--- /dev/null
+++ b/media/baseset/orig_extra/CMakeLists.txt
@@ -0,0 +1,14 @@
+# In case both NFORenum and GRFCodec are found, generate the GRF.
+# Otherwise, just use them from the cache (read: git).
+# This is mainly because not many people have both of these tools installed,
+# so it is cheaper to cache them in git, and only regenerate when you are
+# working on it / have the tools installed.
+if (NFORENUM_FOUND AND GRFCODEC_FOUND)
+ include(CreateGrfCommand REQUIRED)
+ create_grf_command(
+ # We share some files with 'openttd' grf
+ ${CMAKE_CURRENT_SOURCE_DIR}/../openttd/airports.png
+ ${CMAKE_CURRENT_SOURCE_DIR}/../openttd/canals.png
+ ${CMAKE_CURRENT_SOURCE_DIR}/../openttd/chars.png
+ )
+endif (NFORENUM_FOUND AND GRFCODEC_FOUND)