summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 605f4b0a2..825ba3dcd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,13 @@ endif (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake")
+# Use GNUInstallDirs to allow customisation
+# but set our own default data dir
+if (NOT CMAKE_INSTALL_DATADIR)
+ set(CMAKE_INSTALL_DATADIR "share/games")
+endif (NOT CMAKE_INSTALL_DATADIR)
+include(GNUInstallDirs)
+
include(Options)
set_options()
set_directory_options()