summaryrefslogtreecommitdiff
path: root/os/debian/rules
diff options
context:
space:
mode:
authorrubidium <rubidium@openttd.org>2010-07-11 17:51:02 +0000
committerrubidium <rubidium@openttd.org>2010-07-11 17:51:02 +0000
commit283b4c184afea8716de5aca4bff885175c486bd4 (patch)
tree09985aa478f1fd1a7116ee6babd6f5ccf1038790 /os/debian/rules
parent9c97a65b446c682b95a930836a33be49281ea2ab (diff)
downloadopenttd-283b4c184afea8716de5aca4bff885175c486bd4.tar.xz
(svn r20129) -Add [Debian]: debug symbols package
Diffstat (limited to 'os/debian/rules')
-rwxr-xr-xos/debian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/debian/rules b/os/debian/rules
index a34d52049..f2724f899 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -17,7 +17,7 @@ endif
# to be explicit about the dependencies, in case we're not running in a
# clean build root.
override_dh_auto_configure:
- ./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --without-iconv
+ ./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --without-iconv --disable-strip CFLAGS="$(CFLAGS) -g"
# Do some extra installation
override_dh_auto_install:
@@ -41,3 +41,7 @@ override_dh_auto_test:
# target, while there isn't.
override_dh_auto_clean:
[ ! -f Makefile ] || $(MAKE) mrproper
+
+# We want to strip the debug informatiton into the -dbg package.
+override_dh_strip:
+ dh_strip --dbg-package=openttd-dbg