summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Guilloux <glx22@users.noreply.github.com>2021-02-07 16:19:30 +0100
committerGitHub <noreply@github.com>2021-02-07 16:19:30 +0100
commitf7ac2969ef4eae88ef61ec095b0ad081e79168aa (patch)
treebdcb11ee18608c9ec1b8f402eb025bbd6e8171fe /CMakeLists.txt
parent2a6da319b2578944b2ac6b1a267bf880e5c4d34c (diff)
downloadopenttd-f7ac2969ef4eae88ef61ec095b0ad081e79168aa.tar.xz
Fix: [CMake] Restore 'games' as default install bindir (#8629)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fb7a2309..be544316d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,10 +23,13 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake")
set(CMAKE_OSX_DEPLOYMENT_TARGET 10.9)
# Use GNUInstallDirs to allow customisation
-# but set our own default data dir
+# but set our own default data and bin dir
if(NOT CMAKE_INSTALL_DATADIR)
set(CMAKE_INSTALL_DATADIR "share/games")
endif()
+if(NOT CMAKE_INSTALL_BINDIR)
+ set(CMAKE_INSTALL_BINDIR "games")
+endif()
include(GNUInstallDirs)
include(Options)