summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Villiom Podlaski Christiansen <danchr@gmail.com>2020-06-04 21:59:30 +0200
committerCharles Pigott <charlespigott@googlemail.com>2020-06-30 09:43:00 +0100
commitc593893b56f310055c39c1d3c110a0843fc5ba8e (patch)
tree8a3fb04b7361b87f1029b4f4b42fbb3e728edccb /CMakeLists.txt
parent241e3adae8d387618fb52a75273feed9830de64a (diff)
downloadopenttd-c593893b56f310055c39c1d3c110a0843fc5ba8e.tar.xz
Fix: set Mac deployment target
This silences an awful lot of warnings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 675246f5e..bd2111e53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
endif (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake")
+set(CMAKE_OSX_DEPLOYMENT_TARGET 10.9)
# Use GNUInstallDirs to allow customisation
# but set our own default data dir