summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrédéric Simonis <simonisfrederic@gmail.com>2020-06-07 12:06:40 +0200
committerNiels Martin Hansen <nielsm@indvikleren.dk>2020-06-07 13:36:57 +0200
commit90e849198fbac0136ca9bb9149e53f25265eeab5 (patch)
treee6b1cd8ca7fa193395572beaf6b447dd36eeb3bd /CMakeLists.txt
parentfe1925931d671f7ff02c29558b2c61ae9fc8fbb5 (diff)
downloadopenttd-90e849198fbac0136ca9bb9149e53f25265eeab5.tar.xz
Fix: [CMake] Error when SDL2 provides SDL2Config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77ae77cef..7b9788f2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,7 +157,7 @@ link_package(XDG_basedir)
if (NOT OPTION_DEDICATED)
link_package(Fluidsynth)
link_package(SDL)
- link_package(SDL2)
+ link_package(SDL2 TARGET SDL2::SDL2)
link_package(Allegro)
link_package(FREETYPE TARGET Freetype::Freetype)
link_package(Fontconfig TARGET Fontconfig::Fontconfig)