summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfrosch <frosch@openttd.org>2020-12-13 22:24:36 +0100
committerMichael Lutz <michi@icosahedron.de>2020-12-14 23:50:50 +0100
commit5d278b62ccdacbf16b482c1d10247def85ceb71c (patch)
tree03b91cc495cd7b6db0e1bf88c465cb25284874e4 /CMakeLists.txt
parentc9fd85528a804060473364c54248149e96da0508 (diff)
downloadopenttd-5d278b62ccdacbf16b482c1d10247def85ceb71c.tar.xz
Codechange: switch to C++17 on all platforms.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a0dd5b75..15c6e03c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,14 +32,7 @@ set_directory_options()
include(Static)
set_static_if_needed()
-if(MSVC)
- # C++17 for MSVC
- set(CMAKE_CXX_STANDARD 17)
-else()
- # C++11 for all other targets
- set(CMAKE_CXX_STANDARD 11)
-endif()
-
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED YES)
set(CMAKE_CXX_EXTENSIONS NO)