summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorglx22 <glx@openttd.org>2021-05-20 18:28:14 +0200
committerLoïc Guilloux <glx22@users.noreply.github.com>2021-06-10 23:17:29 +0200
commit5d05c4919bd5b5cb9cf1e0123f0c65769e67bd2d (patch)
tree066ea036fe12b963f9ce7fcd04d5e1898c0a29c0 /CMakeLists.txt
parentf4c7d5577ed83d426371f86d780aed01c5370953 (diff)
downloadopenttd-5d05c4919bd5b5cb9cf1e0123f0c65769e67bd2d.tar.xz
Codechange: [WIN32] Reduce manual dynamic loading as WinXP is the minimum version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6cc2f7e2a..fe03b5ae1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -360,6 +360,7 @@ if(WIN32)
-DUNICODE
-D_UNICODE
-DWITH_UNISCRIBE
+ -DPSAPI_VERSION=1
)
target_link_libraries(openttd
@@ -367,6 +368,7 @@ if(WIN32)
winmm
imm32
usp10
+ psapi
)
endif()