summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Pigott <charlespigott@googlemail.com>2020-12-06 18:49:28 +0000
committerCharles Pigott <charlespigott@googlemail.com>2021-01-02 19:46:08 +0000
commit3dfee979a7e486b8d90f6398ea557d2889855059 (patch)
treece9eed1f60a868f30b80d08e2033d7615042f9b4 /CMakeLists.txt
parentc288eba81389d07e27b32f28c6dc4dc518824d2b (diff)
downloadopenttd-3dfee979a7e486b8d90f6398ea557d2889855059.tar.xz
Codechange: Drop libxdg-basedir dependency in favour of finding the directories ourselves
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbde268c4..186e0b8b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,7 +122,6 @@ if(NOT WIN32)
find_package(Fluidsynth)
find_package(Fontconfig)
find_package(ICU OPTIONAL_COMPONENTS i18n lx)
- find_package(XDG_basedir)
else()
find_package(Iconv)
@@ -208,7 +207,6 @@ link_package(PNG TARGET PNG::PNG ENCOURAGED)
link_package(ZLIB TARGET ZLIB::ZLIB ENCOURAGED)
link_package(LIBLZMA TARGET LibLZMA::LibLZMA ENCOURAGED)
link_package(LZO)
-link_package(XDG_basedir)
if(NOT OPTION_DEDICATED)
link_package(Fluidsynth)