summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPatric Stout <truebrain@openttd.org>2021-10-03 16:20:05 +0200
committerGitHub <noreply@github.com>2021-10-03 16:20:05 +0200
commit3046a6ce39d755f50207a2c4a1235069a0eb23fb (patch)
treed3d6477b628b83765bd1b925b74c9d238eb21f63 /CMakeLists.txt
parente404d16929991d1eddd9d37b859d3813be7e18ed (diff)
downloadopenttd-3046a6ce39d755f50207a2c4a1235069a0eb23fb.tar.xz
Change: upgrade Emscripten to 2.0.31 and enable LZMA by default (#9604)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dc733777..f4e08daf4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -305,7 +305,7 @@ if(EMSCRIPTEN)
add_definitions(-s DISABLE_EXCEPTION_CATCHING=0)
# Export functions to Javascript.
- target_link_libraries(WASM::WASM INTERFACE "-s EXPORTED_FUNCTIONS='[\"_main\", \"_em_openttd_add_server\"]' -s EXTRA_EXPORTED_RUNTIME_METHODS='[\"cwrap\"]'")
+ target_link_libraries(WASM::WASM INTERFACE "-s EXPORTED_FUNCTIONS='[\"_main\", \"_em_openttd_add_server\"]' -s EXPORTED_RUNTIME_METHODS='[\"cwrap\"]'")
# Preload all the files we generate during build.
# As we do not compile with FreeType / FontConfig, we also have no way to