summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Guilloux <glx22@users.noreply.github.com>2021-06-10 22:14:08 +0200
committerGitHub <noreply@github.com>2021-06-10 22:14:08 +0200
commit076f3d26c238a9443b367629ab97dc1a5cf9b931 (patch)
treec7e409bf09d846b35db371bddd967ccefb2d6c70 /CMakeLists.txt
parent2924ac48c5013acf18b7577de4f610612d88dd6c (diff)
downloadopenttd-076f3d26c238a9443b367629ab97dc1a5cf9b931.tar.xz
Fix #9329: [CMake] FindVersion.cmake relied on internal cmake variable (#9330)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d060ffbbf..6cc2f7e2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,6 +77,7 @@ add_custom_target(find_version
-DREV_MAJOR=${PROJECT_VERSION_MAJOR}
-DREV_MINOR=${PROJECT_VERSION_MINOR}
-DREV_BUILD=${PROJECT_VERSION_PATCH}
+ -DWINDOWS=${WIN32}
-P "${CMAKE_SOURCE_DIR}/cmake/scripts/FindVersion.cmake"
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
BYPRODUCTS ${GENERATED_SOURCE_FILES}