summaryrefslogtreecommitdiff
path: root/tests/general/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/general/Makefile.am')
-rw-r--r--tests/general/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/tests/general/Makefile.am b/tests/general/Makefile.am
new file mode 100644
index 000000000..551592f96
--- /dev/null
+++ b/tests/general/Makefile.am
@@ -0,0 +1,43 @@
+## Process this file with automake to create Makefile.in.
+
+## Makefile for Autoconf testsuite.
+## Copyright 2000 Free Software Foundation, Inc.
+
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
+
+AUTOMAKE_OPTIONS = gnits
+
+SUITE = suite.at dd.at m4sh.at
+
+# We don't actually distribute the testsuite, since one only
+# needs m4 to build it, m4 being required anyway to install Autoconf.
+EXTRA_DIST = $(SUITE)
+
+TESTS_ENVIRONMENT = \
+ PATH=`pwd`/../../src:$$PATH
+
+TESTS = testsuite
+
+check-local: atconfig
+
+testsuite: $(SUITE)
+ $(M4) -I $(srcdir) atgeneral.m4 suite.at > $@-t1
+ sed 's/[ ]*$$//;/^$$/N;/\n$$/D' $@-t1 > $@-tmp
+ rm -f $@-t1
+ chmod +x $@-tmp
+ mv $@-tmp $@
+
+DISTCLEANFILES = atconfig