summaryrefslogtreecommitdiff
path: root/tests/cut/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/cut/Makefile.am')
-rw-r--r--tests/cut/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/cut/Makefile.am b/tests/cut/Makefile.am
index 06689a7f3..08a3e404e 100644
--- a/tests/cut/Makefile.am
+++ b/tests/cut/Makefile.am
@@ -38,7 +38,8 @@ TESTS = $x-tests
mk_script = $(srcdir)/../mk-script
$(srcdir)/$x-tests: $(mk_script) Test.pm Makefile.am
- $(PERL) -I$(srcdir) -w -- $(mk_script) $(srcdir) $x > $@.n
+ test '$x' = test && prog=../../src/$x || prog=$x; \
+ $(PERL) -I$(srcdir) -w -- $(mk_script) $(srcdir) $$prog > $@.n
mv $@.n $@
chmod 755 $@