summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 224bcd8fc..c151333cd 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -30,13 +30,12 @@ EXTRA_DIST = perm.texi getdate.texi constants.texi fdl.texi
AM_MAKEINFOFLAGS = --no-split
constants.texi: $(top_srcdir)/src/tail.c $(top_srcdir)/src/shred.c
- LC_ALL=C \
- sed -n -e 's/^#define \(DEFAULT_MAX[_A-Z]*\) \(.*\)/@set \1 \2/p' \
- $(top_srcdir)/src/tail.c > t-$@
- LC_ALL=C \
- sed -n -e 's/.*\(DEFAULT_PASSES\)[ =]* \([0-9]*\).*/@set SHRED_\1 \2/p'\
- $(top_srcdir)/src/shred.c >> t-$@
- mv t-$@ $@
+ $(AM_V_GEN)LC_ALL=C; export LC_ALL; \
+ { sed -n -e 's/^#define \(DEFAULT_MAX[_A-Z]*\) \(.*\)/@set \1 \2/p' \
+ $(top_srcdir)/src/tail.c && \
+ sed -n -e 's/.*\(DEFAULT_PASSES\)[ =]* \([0-9]*\).*/@set SHRED_\1 \2/p'\
+ $(top_srcdir)/src/shred.c; } > t-$@ \
+ && mv t-$@ $@
MAINTAINERCLEANFILES = constants.texi