summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index fcf5cfaf7..67f493484 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,10 +108,12 @@ THANKS-to-translators: po/LINGUAS THANKStt.in
# remain in sync.
.PHONY: check-ls-dircolors
check-ls-dircolors:
- dc=$$(sed -n '/static.*ls_codes\[/,/};'/p src/dircolors.c \
- |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
- |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
- ls=$$(sed -n '/static.*indicator_name\[/,/};'/p src/ls.c \
- |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
- |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
+ dc=$$(sed -n '/static.*ls_codes\[/,/};'/p \
+ $(srcdir)/src/dircolors.c \
+ |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
+ |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
+ ls=$$(sed -n '/static.*indicator_name\[/,/};'/\p \
+ $(srcdir)/src/ls.c \
+ |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
+ |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
test "$$dc" = "$$ls"