summaryrefslogtreecommitdiff
path: root/tests/tsort/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1999-08-13 07:57:15 +0000
committerJim Meyering <jim@meyering.net>1999-08-13 07:57:15 +0000
commitbee39b77d9722e8c705c4feb30d44cbf5ecbc3bb (patch)
tree5076748d9bb71c2f32fe788bef6b58628998e0f9 /tests/tsort/Makefile.am
parent18eb7260a178cc66b24cbfd77d3d8207ff8c1350 (diff)
downloadcoreutils-bee39b77d9722e8c705c4feb30d44cbf5ecbc3bb.tar.xz
.
Diffstat (limited to 'tests/tsort/Makefile.am')
-rw-r--r--tests/tsort/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/tsort/Makefile.am b/tests/tsort/Makefile.am
new file mode 100644
index 000000000..b07188d61
--- /dev/null
+++ b/tests/tsort/Makefile.am
@@ -0,0 +1,36 @@
+## Process this file with automake to produce Makefile.in -*-Makefile-*-.
+
+##test-files-begin
+x = tsort
+explicit =
+maint_gen = cycle-1.I cycle-1.X
+run_gen = cycle-1.O cycle-1.E
+##test-files-end
+
+EXTRA_DIST = Test.pm $x-tests $(explicit) $(maint_gen)
+noinst_SCRIPTS = $x-tests
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
+
+TESTS = $x-tests
+
+mk_script = $(srcdir)/../mk-script
+$(srcdir)/$x-tests: $(mk_script) Test.pm
+ $(PERL) -I. -w -- $(mk_script) ../../src/$x > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+MAINTAINERCLEANFILES = $x-tests $(maint_gen)
+CLEANFILES = $(run_gen)
+
+check: $(maint_gen)
+
+Makefile.am: ../Makefile.am.in Test.pm $(mk_script)
+ rm -f $@ $@t
+ sed -n '1,/^##test-files-begin/p' $< > $@t
+ tool=`echo $(subdir)|sed 's/^tests.//;s/-test//'`; \
+ echo "x = $$tool" >> $@t
+ $(PERL) -I. -w -- $(mk_script) --list >> $@t
+ sed -n '/^##test-files-end/,$$p' $< >> $@t
+ mv $@t $@