summaryrefslogtreecommitdiff
path: root/tests/tr/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-09-26 02:59:36 +0000
committerJim Meyering <jim@meyering.net>1996-09-26 02:59:36 +0000
commit9016aac157e9d296c976fcc18e8d660551ea6ce6 (patch)
treef07381b1ed07091eb8a2dbe3e14a846ce14c182f /tests/tr/Makefile.am
parent8c5a8ba9596574cf8ad0f929207eee031c82df5b (diff)
downloadcoreutils-9016aac157e9d296c976fcc18e8d660551ea6ce6.tar.xz
(t): Factor out .in suffix.
Include new test: t16a.
Diffstat (limited to 'tests/tr/Makefile.am')
-rw-r--r--tests/tr/Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/tests/tr/Makefile.am b/tests/tr/Makefile.am
index 7b1b8d46e..0740d81ef 100644
--- a/tests/tr/Makefile.am
+++ b/tests/tr/Makefile.am
@@ -3,16 +3,15 @@
AUTOMAKE_OPTIONS = 1.1c
x = tr
-in = \
- t1.in t2.in t3.in t4.in t5.in t6.in t7.in t8.in t9.in tA.in tB.in \
- tC.in tD.in tE.in tF.in tG.in tH.in tI.in tR0.0.in tR0.1.in tR1.0.in \
- tR1.1.in tR2.in tR3.in tR4.in tR5.in tR6.in ta.in tb.in tc.in td.in \
- te.in tf.in tg.in th.in ti.in tj.in tk.in tl.in tm.in tn.in to.in \
- tp.in tq.in tr.in ts.in tt.in tu.in tv.in tw.in tx.in ty.in tz.in
-
-exp = $(in:.in=.exp)
-out = $(in:.in=.out)
-err = $(in:.in=.err)
+t = \
+ t1 t2 t3 t4 t5 t6 t7 t8 t9 tA tB tC tD tE tF tG tH tI tR0.0 tR0.1 tR1.0 \
+ tR1.1 tR2 tR3 tR4 tR5 tR6 ta tb tc td te tf tg th ti tj tk tl tm tn to \
+ tp tq tr ts tt tu tv tw tx ty tz
+
+in = $(t:=.in)
+exp = $(t:=.exp)
+out = $(t:=.out)
+err = $(t:=.err)
EXTRA_DIST = build-script.pl Test.pm $x-tests $(in) $(exp)
noinst_SCRIPTS = $x-tests