summaryrefslogtreecommitdiff
path: root/tests/tr/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-08-12 03:42:07 +0000
committerJim Meyering <jim@meyering.net>1996-08-12 03:42:07 +0000
commit4fd0132dfca4b1824d2ecc24a1533addd935e3f5 (patch)
tree58686d97f5b10f1323a15b2566219905a837f2bf /tests/tr/Makefile.am
parentbd3627904bc300d2f7ff220bca608b0ba3490263 (diff)
downloadcoreutils-4fd0132dfca4b1824d2ecc24a1533addd935e3f5.tar.xz
.
Diffstat (limited to 'tests/tr/Makefile.am')
-rw-r--r--tests/tr/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/tr/Makefile.am b/tests/tr/Makefile.am
new file mode 100644
index 000000000..b29d61ca7
--- /dev/null
+++ b/tests/tr/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.0
+
+EXTRA_DIST = build-script.pl main test.data.pl
+noinst_SCRIPTS = tr-tests
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g'
+
+TESTS = tr-tests
+
+tr-tests: main build-script test.data.pl
+ ./main test.data.pl > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+SUFFIXES = .pl
+
+.pl:
+ rm -f $@ $@.tmp
+ $(editpl) $< > $@.tmp && chmod +x $@.tmp && mv $@.tmp $@
+
+MAINTAINERCLEANFILES = tr-tests t*.in t*.exp t*.err
+CLEANFILES = t*.out