summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-10-03 13:13:09 +0000
committerJim Meyering <jim@meyering.net>2006-10-03 13:13:09 +0000
commitda9541f18e6985593b73c30d121605e8cff62a7b (patch)
treefa536023ddb705bdc539244b7dd8bf1c74c0f95b /tests/rm/Makefile.am
parentd2e7358a9be5b7f1b816e46f3a2cf151463f2208 (diff)
downloadcoreutils-da9541f18e6985593b73c30d121605e8cff62a7b.tar.xz
With --force (-f), rm no longer fails for ENOTDIR.
* src/remove.c (ignorable_missing): New function. Use it everywhere, rather than open-coding the test. Andreas Schwab reported the ENOTDIR problem. (ignorable_missing): Similarly, don't fail for ENAMETOOLONG. * NEWS: Mention the bug fix. * tests/rm/ignorable: New file. Test for the ENOTDIR case. * tests/rm/ignore-name-too-long: New file. Test for ENAMETOOLONG. * tests/rm/Makefile.am (TESTS): Add the new file names.
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index 8fc7bcab8..2a1339e72 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -21,6 +21,8 @@
AUTOMAKE_OPTIONS = 1.1 gnits
TESTS = \
+ ignore-name-too-long \
+ ignorable \
readdir-bug \
empty-inacc \
dir-nonrecur \