summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-12-20 19:56:20 +0100
committerJim Meyering <jim@meyering.net>2006-12-21 08:58:11 +0100
commitc8ef95eaed944ec70ccd70c077cf465c6311c1b6 (patch)
tree5c83a1915419c58457fff59afe894abf3e00471c /tests/rm/Makefile.am
parentd69fc66d81c7166fe689418f42b7cb900d2a1433 (diff)
downloadcoreutils-c8ef95eaed944ec70ccd70c077cf465c6311c1b6.tar.xz
"rm -rf /etc/motd" (run by non-root) now prints a diagnostic.
* src/remove.c (remove_entry): Handle EACCES for a non-directory, too. Karl Berry reported that a cross-partition "mv /etc/issue ~" failed with the um,... suboptimal diagnostic, "mv: cannot remove `/etc/issue': Not a directory". * tests/rm/Makefile.am (TESTS): Add fail-eacces. * tests/rm/fail-eacces: New file. * NEWS: Mention that both mv and rm are affected.
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index 6670307e8..f63210025 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -21,6 +21,7 @@
AUTOMAKE_OPTIONS = 1.1 gnits
TESTS = \
+ fail-eacces \
one-file-system \
ignorable \
readdir-bug \