summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-01-17 17:02:40 +0100
committerJim Meyering <jim@meyering.net>2007-01-17 17:15:20 +0100
commit0928c2414ab21682600e6572bc628a405fb1ea80 (patch)
treeff030e34af21eb8a8252af6773e54848e18df05b /tests/rm/Makefile.am
parentd1ad73e0bf6a1b6c62e424c1f28cf344fca10600 (diff)
downloadcoreutils-0928c2414ab21682600e6572bc628a405fb1ea80.tar.xz
Make "rm --interactive=never ..." never prompt.
* NEWS: Mention this. * src/remove.h (enum rm_interactive): New ternary type. (struct rm_options) [interactive]: Use it, here -- rather than bool. * src/remove.c (prompt): Reflect type change. * src/mv.c (rm_option_init): Initialize to RMI_NEVER now. * src/rm.c (main): Add a FIXME comment for '-d' option. Adapt to type change of rm_options.interactive. * tests/rm/i-never: New file. Test for the above fix. * tests/rm/Makefile.am (TESTS): Add i-never.
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index ff31f7518..4c212b9d6 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -1,6 +1,6 @@
# Make coreutils tests for "rm". -*-Makefile-*-
-# Copyright (C) 1997, 1998, 2000, 2001, 2002, 2003, 2004, 2005, 2006
+# Copyright (C) 1997, 1998, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007
# Free Software Foundation, Inc.
# This program is free software; you can redistribute it and/or modify
@@ -21,6 +21,7 @@
AUTOMAKE_OPTIONS = 1.1 gnits
TESTS = \
+ i-never \
fail-eacces \
one-file-system \
ignorable \