summaryrefslogtreecommitdiff
path: root/tests/mv/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-11-12 08:22:46 +0100
committerJim Meyering <jim@meyering.net>2006-11-12 08:22:46 +0100
commit28c7ef509e56e5fc1619afcdcf2fc3243bf2da36 (patch)
tree09b038b65b7a76c146847868aabe124d09a64e31 /tests/mv/Makefile.am
parent7c96936a04c6a2eccc40f828aadac3e4be442b10 (diff)
downloadcoreutils-28c7ef509e56e5fc1619afcdcf2fc3243bf2da36.tar.xz
Avoid false-positive when testing via valgrind.
* tests/mv/atomic: Grep strace output for a more specific pattern than just "unlink", since that got a false positive when testing under valgrind: unlink("/tmp/valgrind_proc_9657_cmdline_A51E9991") = 0 * tests/mv/Makefile.am (TESTS_ENVIRONMENT): Define EGREP.
Diffstat (limited to 'tests/mv/Makefile.am')
-rw-r--r--tests/mv/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/mv/Makefile.am b/tests/mv/Makefile.am
index 927bac89b..57581cd88 100644
--- a/tests/mv/Makefile.am
+++ b/tests/mv/Makefile.am
@@ -46,5 +46,6 @@ TESTS = \
EXTRA_DIST = $(TESTS) vfat
TESTS_ENVIRONMENT = \
PERL="$(PERL)" \
+ EGREP="$(EGREP)" \
PATH="$(VG_PATH_PREFIX)`pwd`/../../src$(PATH_SEPARATOR)$$PATH" \
PROG=mv