summaryrefslogtreecommitdiff
path: root/tests/misc/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-03-21 10:37:26 +0100
committerJim Meyering <meyering@redhat.com>2008-03-21 20:58:15 +0100
commita0851554bd52038ed47e46ee521ce74a5a09f747 (patch)
tree624025f9d2b1e17429bd4934da21942dab3b3039 /tests/misc/Makefile.am
parent4f812540a26ad98b52fac71e54049253359caf19 (diff)
downloadcoreutils-a0851554bd52038ed47e46ee521ce74a5a09f747.tar.xz
ptx: avoid heap overrun for backslash at end of optarg string
* src/ptx.c (copy_unescaped_string): Ignore a lone backslash at end of string. Reported by Cristian Cadar, Daniel Dunbar and Dawson Engler. Details here: <http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/13005>. * tests/misc/Makefile.am (TESTS): Add ptx-overrun. * tests/misc/ptx-overrun: New file. Test for the above fix. * NEWS: Mention the fix. Signed-off-by: Jim Meyering <meyering@redhat.com>
Diffstat (limited to 'tests/misc/Makefile.am')
-rw-r--r--tests/misc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/misc/Makefile.am b/tests/misc/Makefile.am
index 2be132f30..f3ed13209 100644
--- a/tests/misc/Makefile.am
+++ b/tests/misc/Makefile.am
@@ -1,6 +1,6 @@
# Make miscellaneous coreutils tests. -*-Makefile-*-
-# Copyright (C) 2001-2007 Free Software Foundation, Inc.
+# Copyright (C) 2001-2008 Free Software Foundation, Inc.
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -38,6 +38,7 @@ TESTS = \
ls-time \
ls-misc \
date \
+ ptx-overrun \
xstrtol \
od \
mktemp \