summaryrefslogtreecommitdiff
path: root/tests/misc/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-06-08 20:13:37 +0000
committerJim Meyering <jim@meyering.net>2006-06-08 20:13:37 +0000
commit790892db657ac79b0ba5f7a69cc7e70eb4fed8e0 (patch)
tree6d768a6a1af6cab8a813c1173dddc93c352f4751 /tests/misc/Makefile.am
parentcad27cdc2ea46ec401b71b76a92fcf3bc1d094e0 (diff)
downloadcoreutils-790892db657ac79b0ba5f7a69cc7e70eb4fed8e0.tar.xz
Ensure that cat works with any of the options, -A -v -e -E -T,
when applied to files in /proc and /sys, even when the FIONREAD ioctl produces nonsensical results. Before this change, cat would produce no output (or truncated output), for some linux kernels. * src/cat.c (write_pending): New function, factored out of cat. (cat): Also interpret a negative ioctl/FIONREAD count as indicating that there are bytes to read. Some versions of linux-2.6.16 do that. Write any pending output before returning. Reported by Dan Jacobson in <http://bugs.debian.org/370583>. * NEWS: Mention this bug fix. * tests/misc/cat-proc: New file. Test for the above. * tests/misc/Makefile.am (TESTS): Add cat-proc.
Diffstat (limited to 'tests/misc/Makefile.am')
-rw-r--r--tests/misc/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/misc/Makefile.am b/tests/misc/Makefile.am
index 5f6b07a92..696b9fdc1 100644
--- a/tests/misc/Makefile.am
+++ b/tests/misc/Makefile.am
@@ -18,6 +18,7 @@ TESTS_ENVIRONMENT = \
# will execute the test script rather than the standard utility.
TESTS = \
+ cat-proc \
base64 \
basename \
close-stdout \