summaryrefslogtreecommitdiff
path: root/tests/join/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-10-18 04:55:16 +0000
committerJim Meyering <jim@meyering.net>1996-10-18 04:55:16 +0000
commit97f0f916a206e5fc5c26ea6e2e4ecd04b849e1d1 (patch)
tree81f45c95fd3a6d8e6d6c5f0c1f93ddee3d7cbf9f /tests/join/Makefile.am
parent42e52b501786f0802978685b3f61382c4ab725e4 (diff)
downloadcoreutils-97f0f916a206e5fc5c26ea6e2e4ecd04b849e1d1.tar.xz
.
Diffstat (limited to 'tests/join/Makefile.am')
-rw-r--r--tests/join/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/join/Makefile.am b/tests/join/Makefile.am
new file mode 100644
index 000000000..5a7b8068a
--- /dev/null
+++ b/tests/join/Makefile.am
@@ -0,0 +1,33 @@
+## Process this file with automake to produce Makefile.in.
+
+x = join
+t = t1a t1b t1c t1d t1e t1f t2a t2b t2c t3a t4a t4b t4c t4d t4e t5a t5b \
+t5c t5d t5e t5f t5g t5h t5i t5j t5k t5l t5m t6a t6b t6c t7a t8a t8b t9a
+
+in1 = $(t:=.in1)
+in2 = $(t:=.in2)
+exp = $(t:=.exp)
+out = $(t:=.out)
+err = $(t:=.err)
+
+EXTRA_DIST = build-script.pl Test.pm $x-tests $(in1) $(in2) $(exp)
+noinst_SCRIPTS = $x-tests build-script
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
+
+TESTS = $x-tests
+
+$x-tests: @MAINT@build-script Test.pm
+ ./build-script ../../src/$x > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+SUFFIXES = .pl
+
+.pl:
+ rm -f $@ $@.tmp
+ $(editpl) $< > $@.tmp && chmod +x $@.tmp && mv $@.tmp $@
+
+MAINTAINERCLEANFILES = $x-tests $(in) $(exp)
+CLEANFILES = $(out) $(err)