summaryrefslogtreecommitdiff
path: root/tests/join/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-12-18 01:25:45 +0000
committerJim Meyering <jim@meyering.net>1996-12-18 01:25:45 +0000
commit6c4752448111b6502b9a8ffc202c565b122f549b (patch)
tree887b55ed118be7cc197af1a29bde3679119aa63b /tests/join/Makefile.am
parent300c151b8bdd08ce43a017879bfdfad294c7ee9f (diff)
downloadcoreutils-6c4752448111b6502b9a8ffc202c565b122f549b.tar.xz
(.pl): Make generated file read-only so
I don't accidentally modify it instead of the one with the .pl suffix.
Diffstat (limited to 'tests/join/Makefile.am')
-rw-r--r--tests/join/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/join/Makefile.am b/tests/join/Makefile.am
index dfed245c5..ec18995de 100644
--- a/tests/join/Makefile.am
+++ b/tests/join/Makefile.am
@@ -27,7 +27,9 @@ SUFFIXES = .pl
.pl:
rm -f $@ $@.tmp
- $(editpl) $< > $@.tmp && chmod +x $@.tmp && mv $@.tmp $@
+ $(editpl) $< > $@.tmp
+ chmod +x-w $@.tmp
+ mv $@.tmp $@
MAINTAINERCLEANFILES = $x-tests $(in) $(exp)
CLEANFILES = $(out) $(err)