summaryrefslogtreecommitdiff
path: root/tests/factor/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1997-02-18 02:43:59 +0000
committerJim Meyering <jim@meyering.net>1997-02-18 02:43:59 +0000
commitbf8b53e78b92bb53193f355d9d735c23a6b7d08b (patch)
tree95b5c51d00009774ce6f91f63e8b5e3896945d8a /tests/factor/Makefile.am
parent1ee3e32c80ccb1a083e7bd74dbb64de4e700a479 (diff)
downloadcoreutils-bf8b53e78b92bb53193f355d9d735c23a6b7d08b.tar.xz
.
Diffstat (limited to 'tests/factor/Makefile.am')
-rw-r--r--tests/factor/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/factor/Makefile.am b/tests/factor/Makefile.am
new file mode 100644
index 000000000..b29961cb6
--- /dev/null
+++ b/tests/factor/Makefile.am
@@ -0,0 +1,45 @@
+## Process this file with automake to produce Makefile.in.
+
+##test-files-begin
+x = date
+explicit =
+maint_gen = t1.exp t2.exp t3.exp t4.exp t5.exp t6.exp t7.exp t8.exp t9.exp \
+tleap-1.exp
+run_gen = t1.out t1.err t2.out t2.err t3.out t3.err t4.out t4.err t5.out \
+t5.err t6.out t6.err t7.out t7.err t8.out t8.err t9.out t9.err tleap-1.out \
+tleap-1.err
+##test-files-end
+
+EXTRA_DIST = mk-script.pl Test.pm $x-tests $(explicit) $(maint_gen)
+noinst_SCRIPTS = $x-tests
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
+
+TESTS = $x-tests
+
+$x-tests: @MAINT@mk-script Test.pm
+ ./mk-script ../../src/$x > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+SUFFIXES = .pl
+
+.pl:
+ rm -f $@ $@.tmp
+ $(editpl) $< > $@.tmp
+ chmod +x-w $@.tmp
+ mv $@.tmp $@
+
+MAINTAINERCLEANFILES = $x-tests $(maint_gen)
+CLEANFILES = $(run_gen)
+
+@MAINT@rebuild-check: Test.pm mk-script
+@MAINT@ rb=rb-check; rm -f $rb; \
+@MAINT@ m_template=../Makefile.am.in; \
+@MAINT@ sed -n '1,/^##test-files-begin/p' $$m_template > $$rb; \
+@MAINT@ tool=`echo $(subdir)|sed 's/^tests.//;s/-test//'`; \
+@MAINT@ echo "x = $$tool" >> $$rb; \
+@MAINT@ ./mk-script --list >> $$rb; \
+@MAINT@ sed -n '/^##test-files-end/,$$p' $$m_template >> $$rb; \
+@MAINT@ diff -u Makefile.am $$rb && echo ok || echo no