summaryrefslogtreecommitdiff
path: root/tests/date/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1997-01-21 04:21:48 +0000
committerJim Meyering <jim@meyering.net>1997-01-21 04:21:48 +0000
commit8011a147de41e69c0966657a8ff1e125d9fb9375 (patch)
tree1b4d34a80f0be94abc88fd23ca0770a904cbd9d9 /tests/date/Makefile.am
parent3cca257a3b0c9295b667b27f84f43f06a8e1f56b (diff)
downloadcoreutils-8011a147de41e69c0966657a8ff1e125d9fb9375.tar.xz
.
Diffstat (limited to 'tests/date/Makefile.am')
-rw-r--r--tests/date/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/tests/date/Makefile.am b/tests/date/Makefile.am
new file mode 100644
index 000000000..21f1c0fe5
--- /dev/null
+++ b/tests/date/Makefile.am
@@ -0,0 +1,41 @@
+## Process this file with automake to produce Makefile.in.
+
+##test-files-begin
+x = date
+explicit =
+maint_gen =
+##test-files-end
+
+EXTRA_DIST = mk-script.pl Test.pm $x-tests $(explicit) $(maint_gen)
+noinst_SCRIPTS = $x-tests
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
+
+TESTS = $x-tests
+
+$x-tests: @MAINT@mk-script Test.pm
+ ./mk-script ../../src/$x > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+SUFFIXES = .pl
+
+.pl:
+ rm -f $@ $@.tmp
+ $(editpl) $< > $@.tmp
+ chmod +x-w $@.tmp
+ mv $@.tmp $@
+
+MAINTAINERCLEANFILES = $x-tests $(maint_gen)
+CLEANFILES = $(run_gen)
+
+@MAINT@rebuild-check: Test.pm mk-script
+@MAINT@ rb=rb-check; rm -f $rb; \
+@MAINT@ m_template=../Makefile.am.in; \
+@MAINT@ sed -n '1,/^##test-files-begin/p' $$m_template > $$rb; \
+@MAINT@ tool=`echo $(subdir)|sed 's/^tests.//;s/-test//'`; \
+@MAINT@ echo "x = $$tool" >> $$rb; \
+@MAINT@ ./mk-script --list >> $$rb; \
+@MAINT@ sed -n '/^##test-files-end/,$$p' $$m_template >> $$rb; \
+@MAINT@ diff -u Makefile.am $$rb && echo ok || echo no