summaryrefslogtreecommitdiff
path: root/tests/cut/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-12-22 03:25:05 +0000
committerJim Meyering <jim@meyering.net>1996-12-22 03:25:05 +0000
commita5b6fae599071084e509e78a6f0b8ef65593589b (patch)
tree35b6933a4e948a1fa204487889ed9763b6435662 /tests/cut/Makefile.am
parentb660d78cf53f1dde2a25865a6f5318543ea99d04 (diff)
downloadcoreutils-a5b6fae599071084e509e78a6f0b8ef65593589b.tar.xz
.
Diffstat (limited to 'tests/cut/Makefile.am')
-rw-r--r--tests/cut/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/cut/Makefile.am b/tests/cut/Makefile.am
index 1056d1d11..c46eb52f2 100644
--- a/tests/cut/Makefile.am
+++ b/tests/cut/Makefile.am
@@ -1,8 +1,7 @@
## Process this file with automake to produce Makefile.in.
-x = cut
-
##test-files-begin
+x = cut
explicit =
maint_gen = t1.in t1.exp t2.in t2.exp t3.in t3.exp t4.in t4.exp t5.in t5.exp \
t6.in t6.exp t7.in t7.exp t8.in t8.exp t9.in t9.exp ta.in ta.exp tb.in tb.exp \
@@ -47,7 +46,10 @@ CLEANFILES = $(run_gen)
@MAINT@rebuild-check: Test.pm mk-script
@MAINT@ rb=rb-check; rm -f $rb; \
-@MAINT@ sed -n '1,/^##test-files-begin/p' Makefile.am > $$rb; \
+@MAINT@ m_template=../Makefile.am.in; \
+@MAINT@ sed -n '1,/^##test-files-begin/p' $$m_template > $$rb; \
+@MAINT@ tool=`echo $(subdir)|sed 's/^tests.//;s/-test//'`; \
+@MAINT@ echo "x = $$tool" >> $$rb; \
@MAINT@ ./mk-script --list >> $$rb; \
-@MAINT@ sed -n '/^##test-files-end/,$$p' Makefile.am >> $$rb; \
+@MAINT@ sed -n '/^##test-files-end/,$$p' $$m_template >> $$rb; \
@MAINT@ diff -u Makefile.am $$rb && echo ok || echo no