summaryrefslogtreecommitdiff
path: root/tests/cut/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1996-09-30 00:24:30 +0000
committerJim Meyering <jim@meyering.net>1996-09-30 00:24:30 +0000
commit78315499ba8d131e2d9eba720ef5edbfd1b09e99 (patch)
tree2a2bd6aa4b7d8b591a37417bb2e3104a02403667 /tests/cut/Makefile.am
parente666e3459e721d0f804feb537320c6e4b0c3d65c (diff)
downloadcoreutils-78315499ba8d131e2d9eba720ef5edbfd1b09e99.tar.xz
.
Diffstat (limited to 'tests/cut/Makefile.am')
-rw-r--r--tests/cut/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/cut/Makefile.am b/tests/cut/Makefile.am
new file mode 100644
index 000000000..0be09be84
--- /dev/null
+++ b/tests/cut/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.1c
+
+x = cut
+t = t1 t2 t3 t4 t5 t6 t7 t8 t9 tA tB tC tD ta tb tc td te tf tg th \
+ti tj tk tl tm tn to tp tq tr ts tt tu tv tw tx ty tz
+
+in = $(t:=.in)
+exp = $(t:=.exp)
+out = $(t:=.out)
+err = $(t:=.err)
+
+EXTRA_DIST = build-script.pl Test.pm $x-tests $(in) $(exp)
+noinst_SCRIPTS = $x-tests build-script
+
+PERL = @PERL@
+editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,@srcdir@,g'
+
+TESTS = $x-tests
+
+$x-tests: @MAINT@build-script Test.pm
+ ./build-script ../../src/$x > $@.n
+ mv $@.n $@
+ chmod 755 $@
+
+SUFFIXES = .pl
+
+.pl:
+ rm -f $@ $@.tmp
+ $(editpl) $< > $@.tmp && chmod +x $@.tmp && mv $@.tmp $@
+
+MAINTAINERCLEANFILES = $x-tests $(in) $(exp)
+CLEANFILES = $(out) $(err)