summaryrefslogtreecommitdiff
path: root/tests/cp/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-12-14 17:17:31 +0100
committerJim Meyering <jim@meyering.net>2006-12-14 17:17:31 +0100
commita6a1e73c0a1185702d33b3694c6fb8d9642340e8 (patch)
tree37d28bb5744dccb07dbcb5641d278561bfef359c /tests/cp/Makefile.am
parentc3154b2947abbb8d03a412d5874fcceb1fc29393 (diff)
downloadcoreutils-a6a1e73c0a1185702d33b3694c6fb8d9642340e8.tar.xz
Test for a hard-to-detect race fix, using gdb.
* tests/cp/open-perm-race: New file, to test for the cp --preserve=ownership fix of 2006-12-06. * tests/cp/Makefile.am (TESTS_ENVIRONMENT): Define abs_top_builddir. (TESTS): Add open-perm-race.
Diffstat (limited to 'tests/cp/Makefile.am')
-rw-r--r--tests/cp/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/cp/Makefile.am b/tests/cp/Makefile.am
index 998b59fbd..1fb58de8a 100644
--- a/tests/cp/Makefile.am
+++ b/tests/cp/Makefile.am
@@ -21,6 +21,7 @@
AUTOMAKE_OPTIONS = 1.1 gnits
TESTS = \
+ open-perm-race \
backup-dir \
src-base-dot \
sparse \
@@ -33,7 +34,8 @@ TESTS = \
perm cp-HL cp-i special-bits link dir-rm-dest cp-parents deref-slink \
dir-vs-file into-self
EXTRA_DIST = $(TESTS) trailing-slash
-TESTS_ENVIRONMENT = \
- MAKE=$(MAKE) \
- CONFIG_HEADER=$(CONFIG_HEADER) \
+TESTS_ENVIRONMENT = \
+ MAKE=$(MAKE) \
+ abs_top_builddir=$(abs_top_builddir) \
+ CONFIG_HEADER=$(CONFIG_HEADER) \
PATH="$(VG_PATH_PREFIX)`pwd`/../../src$(PATH_SEPARATOR)$$PATH"