summaryrefslogtreecommitdiff
path: root/tests/cp/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-04-17 23:34:45 +0200
committerJim Meyering <meyering@redhat.com>2008-04-21 00:01:51 +0200
commit512e111a926fedbd7dc7b0875ab837dbb7d2a7a6 (patch)
treef77cdb2c6bfc71f0560cf073324365c0a3e65526 /tests/cp/Makefile.am
parentd25bf9dceb90dcb91f8af57aff433273c7145ff7 (diff)
downloadcoreutils-512e111a926fedbd7dc7b0875ab837dbb7d2a7a6.tar.xz
Revamp test-related Makefiles.
One side-effect of this change is that "make check" now works even if you put "." early in your shell's search PATH (don't do that!). Remove all test-related Makefile.am files, except those generated by mk-script. Instead, tests/Makefile.am now lists not only the tests directly under tests/, but also those in tests/*/ that are not generated by mk-script, e.g., cp/abuse, cp/acl, mv/i-1, etc. A lot of these changes are like this: -. $srcdir/../lang-default +. $top_srcdir/tests/lang-default -. $srcdir/../test-lib.sh +. $top_srcdir/tests/test-lib.sh * configure.ac (AC_CONFIG_FILES): Remove corresponding Makefiles. * tests/check.mk (vc_exe_in_TESTS): Relax syntax requirements. * tests/rwx-to-mode: Remove file. Rewritten as... * tests/test-lib.sh (rwx_to_mode_): ...this new function. * tests/Makefile.am (EXTRA_DIST): Remove rwx-to-mode. (SUBDIRS): Remove each dir with a removed Makefile.am. (EXTRA_DIST): Add $(TESTS). (TESTS): Add over 300 entries.
Diffstat (limited to 'tests/cp/Makefile.am')
-rw-r--r--tests/cp/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/tests/cp/Makefile.am b/tests/cp/Makefile.am
deleted file mode 100644
index 28ebd35a6..000000000
--- a/tests/cp/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-# Make coreutils tests for cp. -*-Makefile-*-
-
-# Copyright (C) 1997-2001, 2003, 2005-2008 Free Software Foundation, Inc.
-
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-TESTS = \
- special-f \
- parent-perm \
- abuse \
- proc-zero-len \
- thru-dangling \
- cp-a-selinux \
- file-perm-race parent-perm-race \
- existing-perm-race \
- backup-dir \
- src-base-dot \
- sparse \
- link-no-deref \
- cp-deref \
- acl \
- preserve-2 r-vs-symlink link-preserve preserve-gid \
- backup-1 no-deref-link1 no-deref-link2 no-deref-link3 backup-is-src \
- same-file cp-mv-backup symlink-slash slink-2-slink fail-perm dir-slash \
- perm cp-HL cp-i special-bits link dir-rm-dest cp-parents deref-slink \
- dir-vs-file into-self
-EXTRA_DIST = $(TESTS) trailing-slash
-
-include $(top_srcdir)/tests/check.mk