summaryrefslogtreecommitdiff
path: root/tests/cp/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2006-09-20 17:32:14 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2006-09-20 17:32:14 +0000
commit2a01141018637fc06604335aea673dff95efd033 (patch)
tree4cf78e6c99e09e4a5d947e465b92829fc7a43bae /tests/cp/Makefile.am
parentfae30e1af9aec9486b0a278c1c5e7b8c6abba498 (diff)
downloadcoreutils-2a01141018637fc06604335aea673dff95efd033.tar.xz
* NEWS: Document fix for cp -i and mv -i.
* src/copy.c (copy_internal): With -i, prompt even if the source is a directory and the destination is not. This is required by POSIX and gives the user a chance to bail out before failing. * tests/cp/Makefile.am (TESTS): Add cp-i. * tests/cp/cp-i: New file. * tests/mv/Makefile.am (TESTS): Add i-5. * tests/mv/i-5: New file.
Diffstat (limited to 'tests/cp/Makefile.am')
-rw-r--r--tests/cp/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/cp/Makefile.am b/tests/cp/Makefile.am
index 0b42f3a8a..832bb328e 100644
--- a/tests/cp/Makefile.am
+++ b/tests/cp/Makefile.am
@@ -29,7 +29,7 @@ TESTS = \
preserve-2 r-vs-symlink link-preserve \
backup-1 no-deref-link1 no-deref-link2 no-deref-link3 backup-is-src \
same-file cp-mv-backup symlink-slash slink-2-slink fail-perm dir-slash \
- perm cp-HL special-bits link dir-rm-dest cp-parents deref-slink \
+ perm cp-HL cp-i special-bits link dir-rm-dest cp-parents deref-slink \
dir-vs-file into-self
EXTRA_DIST = $(TESTS) trailing-slash
TESTS_ENVIRONMENT = \